Tips/Hardware/NWHW

ALAXALAまとめ

  • AX2400S/AX2500Sシリーズをたまたま使うことになったので。

機器構成

  • Alaxala AX2430S
    • 1Gbps
    • -24T: 1G 24ポート(gigabitethernet 0/1-4はSFP排他)
    • -48T: 1G 48ポート(gigabitethernet 0/1-4はSFP排他)
    • 末尾に2Xが付くと10G(XFP)2ポート(tengigabitethernetが末尾ポートに付く)
      • 24T2Xだとtengigabitethernet 0/25-26、48T2Xだとtengigabitethernet 0/49-50
    • 末尾にDが付くとDCモデル
    • 2015年頃に販売終了

Alaxalaの特徴

  • Cisco Catalystを使っていればなんとなく見当が付く。
    • でも結構違うところがあってたまに引っかかる。
      • running-configにパスワード情報が入っていなかったり、一発初期化のコマンドがなかったり。
      • NECとHITACHIの合弁会社だったので、コマンドや内部構造のスマートさはイマイチかも。
  • ファームウェアはサポートを契約(製品を購入してユーザ登録)していないともらえない。
    • (´ε`;)うーん。。。
    • そのためか分からないけど、ヤフオクでは結構安い。
      • L3のAX3640S 48ポートが2000円台の投げ売り状態。
  • ステータスランプは点灯。
    • 動作時に点滅していないので、固まってるように見えてしまい、どうにも落ち着かない。
  • 黒い。
    • 筐体デザインも素朴で堅実なイメージのデザインだし、社名もかっこいいと思う。
    • ala x ala(翼×翼)
    • 「あぁぁぁ」
  • 今後は?
    • AlliedTelesisと業務提携しているらしい。
    • HITACHIが手を引いて日本産業パートナーズが入ってきた。
    • 東証のシステムの初代・二代目ダウン当事者。あの流量を捌く実績を持っていることは確か。なお三代目はFUJITSU。

ハードウェア系

コンソール

  • 通信設定
    • 9600bps, 8bit, no parity, stop 1bit, no flow
  • コンソーツ通信速度を19200bpsにする
    (config)# line console 0
    (config-line)# speed 19200
    • 9600bpsで十分だと思う。速さを求めるならTelnetの方が良いのでは。

デフォルトリスタート

  • パスワード無効化
    • 本体リセットスイッチ5秒
  • 起動後にパスワードが初期に戻る。
    • ユーザ名 operator パスワード (なし)

電源・ログイン

  • 停止
    # reload stop
  • ログアウト
    logout
  • 自動ログアウト
    set exec-timeout
  • ユーザ作成
    # adduser username
    • rootやadminは機器内部ユーザーとして予約されているため、利用不可。
  • ユーザ削除
    # rmuser username
  • ユーザーパスワード変更
    $ password
    • 管理者モードの場合は後ろにユーザ名を指定して他のユーザのパスワードも変更できる。
  • 管理者(昇格)パスワード変更
    # password enable-mode
  • パスワードの削除
    # clear password
    # clear password enable-mode
    • コンフィグの削除をしてもユーザ情報は消えない。
  • 再起動
    reload
    • 再起動前にダンプを取るか聞かれる

LED

  • ST1: 装置状態
    • 緑点灯: 動作中
    • 緑点滅: 起動中
    • 赤点滅: 部分故障
    • 赤点灯: 致命的障害
    • 消灯: 電源OFFまたは電源異常
      • 動作中が点滅じゃないと不安になる病をお持ちの方は注意されたし。
  • ポート(RJ45): ポートの状態
    • 緑点灯: リンク
    • 橙点灯: 回線障害
    • 消灯: リンク障害または閉塞
    • 緑点滅: 送受信中

障害時の挙動と通信可否

  • ポート障害
    • 当該ポートの自動復旧を無限回
    • 当該ポートの通信中断
  • メインボード障害
    • 自動復旧を6回/1時間→7回目の障害で停止→1時間経過で自動復旧再開
    • 全ポートの通信中断
  • 電源障害
    • 停止(冗長化している場合は停止しない)
    • 通信中断(冗長化している場合は中断なし)
  • FAN障害
    • 残りの正常なFANを高速回転
    • 中断なし

省電力

  • ポート電力供給OFF
    shutdown
  • 一時的にポート電力供給OFF(configに反映されない)
    inactive
  • スケジュールでポート電力供給OFF
    schedule-power-control shutdown
    schedule-power-control time-range
    show power-control schedule-power-control

メモリーカード

  • SDカード
    • AX2400S系ではSDHCやSDXCは認識しなかった。
  • メモリーカードの情報を表示
    > show mc
  • メモリーカードのファイルをコピー
    > cp 20210104_L2-test.conf mc-file 20210104_L2-test.conf
    • ドライブ名とかディレクトリ形式ではなく、mc-fileを前に置くとメモリーカード指定になる模様。

運用系コマンド

モード変更

  • 装置管理者モードに昇格 (#プロンプト)
    > enable
  • 一般ユーザモードに戻る (>プロンプト)
    # disable
  • 現在のコマンド入力モード終了
    quit / exit
  • コンフィグレーションコマンドモード
    # configure / configure terminal
  • プロンプトが(config)# になる
  • ページング
    set terminal pager
    • 後ろにenableまたはdisableを付けられる。

コンフィグレーション

  • CiscoやJuniperのように一発初期化コマンドがないので注意。
    • パスワード系も別。
    • ここのコマンドだけでもまだ何か残っていそうな気がする。
  • コンフィグレーションの保存
    # save / write
    • Ciscoの間隔で"write memory"とタイプすると、memoryというファイルに保存しやがるので注意。
  • ランニングコンフィグレーション
    # show running-config / show
  • スタートアップコンフィグレーション
    # show startup-config
  • ランニングコンフィグレーションの削除(初期化)
    # erase configuration
  • 運用ログの消去
    > clear logging
  • ダンプの消去
    > erase dumpfile all
  • コマンド履歴の消去
    # rm .clihistory
    # reload
    • 直後に再起動しないとexit時に.clihistoryが作成される模様

zmodemファイル転送

  • コンフィグレーションファイルをスイッチに転送し、スタートアップコンフィグに上書き
    > cd /usr/home/operator
    > zmodem get backup.cnf
    # copy /usr/home/operator/backup.cnf startup-config
  • スタートアップコンフィグをコンソールに転送
    > zmodem put startup-config

FTPファイル転送

  • 他のFTPサーバへログイン
    > ftp 192.168.0.1
  • 他のFTPサーバへファイルコピー
    > copy startup-config ftp://username@192.168.0.1/backup.cnf
  • FTPサーバ許可
    # ftp-server
  • TFTP転送
    > tftp

telnet

  • telnet許可、最大3ユーザ同時ログイン
    #(config) line vty 0 2
  • アクセス制御(IPv4)
    (config)# ip access-list standard REMOTE
    (config-std-nacl)# permit 192.168.0.0 0.0.0.255
    (config-std-nacl)# exit
    (config)# line vty 0 2
    (config-line)# ip access-group REMOTE in
    • permitはmaskではなくwildcardで指定する(上の例だと192.168.0.0-255)

NTP

  • タイムオフセット設定
    (config)# clock timezone JST +9
  • 時刻設定
    # set clock 2010070038
    • 2020.10.07 00:38
      • 西暦を下2桁で入力させる古き良き時代。
  • NTPサーバと同期(クライアント)
    (config)# ntp server 192.168.1.100
    • 1000秒以上開きのあるサーバとは同期しない。
    • 複数のサーバを指定すると、prefer昇順→stratum昇順→任意(ランダム?)順で選択される。
  • NTPサーバ設定(サーバ・クライアント)
    # ntp peer 192.168.1.100
    • 1000秒以上開きのあるサーバとは同期しない。
    • 同期が確立する条件がいろいろあるっぽい。
    • 面倒なのでset clockで大体合わせた後にntp serverを使おうと思う。
  • 時刻の確認
    > show clock
  • NTPサーバの動作状態
    > show ntp associations

DNS, ホスト名

  • ホスト名の設定
    #(config) hostname L2-test
  • ドメイン名とネームサーバの設定
    # ip domain name example.com
    # ip name-server 192.168.0.1
  • ホスト名の設定
    # ip host L2-test 192.168.0.1

装置

  • 装置の状態
    > show system
  • FAN,電源,温度,累積稼働時間
    > show environment
  • 温度履歴情報
    > show environment temperature-logging
  • FANの運転モード設定
    (config)# system fan mode 2
    1: 静音重視 2:冷却重視
  • 装置内メモリ(ファイルシステム)の使用状況
    > show flash
  • 運用ログ情報
    > show logging
    > show logging | grep hoge
    • パイプやgrepが使える
  • 運用メッセージの出力抑止
    > set logging console fisable E5
  • 情報の一括バックアップ(FTP)
    # backup ftp 192.168.0.1 backup.dat
    • ftpではなくメモリーカード(mc)でも可能
  • 情報のリストア(FTP)
    # restore ftp 192.168.0.1 backup.dat

ポート系

インタフェース

  • インタフェース0/1のランニングコンフィグレーションを表示
    > show interface gigabitethernet 0/1
  • 設定済みインターフェース情報を表示
    > show interface
  • 全てのポートの動作状況
    > show port
  • インタフェースの設定モード(config-if)に入る(個別)
    # interface gigabitethernet 0/1
  • インタフェースの設定モード(config-if-range)に入る(一括)
    # interface range gigabitethernet 0/1-10, gigabitethernet 0/15-20, tengigabitethernet 0/25
  • インタフェースをシャットダウン
    (config-if)# shutdown
    • 解除は no shutdown
    • 一時的(再起動したらactiveになる)は inactivate gigabitethernet 0/1
  • イーサネット速度の設定
    (config-if)# speed 10
    • 10, 100, 1000, auto
    • auto 10 100 のように、オートネゴに選択肢を与えることもできる。
  • 全二重・半二重固定の設定
    (config-if)# duplex full
    • full, half, auto
  • 選択型ポートの設定
    (config-if)# media-type rj45
    • rj45, sfp
    • デフォルトはsfpになっているっぽい
    • xfp(10G)は個別でポート(tengigabitethernet)が振られている。大抵末尾に振られている。

VLAN, IPアドレス

  • ポートの種類
    • アクセスポート:Untaggedフレームを扱うポート。いわゆる通常のポート。
    • トランクポート:VLAN Taggedフレームを扱うポート。
    • トンネリングポート:VLAN TaggedフレームとUntaggedフレームを混在させるポート。
    • 他にプロトコルポート(フレームプロトコル)やMACポートがある。
  • VLAN設定状態
    > show vlan
  • VLAN通信状態
    > show vlan 100 detail
  • VLAN ID一覧
    > show vlan summary
  • VLANリスト
    > show vlan list
  • VLAN 100を有効(active)に設定
    (config)# vlan 100
    (config-vlan)# state active
    (config-vlan)# name "server-A VLAN100"
  • 無効
    (config)# vlan 100
    (config-vlan)# state suspend
  • インタフェース0/1をアクセスポート(VLAN 100)に設定
    (config)# interface gigabitethernet 0/1
    (config-if)# switchport mode access
    (config-if)# switchport access vlan 100
  • 解除
    (config-if)# no switchport access vlan
  • インターフェース0/2をトランクポート(VLAN 100-110)に設定
    (config)# interface gigabitethernet 0/2
    (config-if)# switchport mode trunk
    (config-if)# switchport trunk allowed vlan 100-110
  • トランクポートの追加・削除
    (config-if)# switchport trunk allowed vlan add 111
    (config-if)# switchport trunk allowed vlan remove 111
  • ポートチャネル10をトランクポートに設定
    (config)# interface port-channel 10
    (config-if)# switchport mode trunk
    (config-if)# switchport trunk allowed vlan 100-110
  • ネイティブVLANの設定
    (config-if)# switchport trunk native vlan 100
    • Untaggedフレームが流れてきたときはVLAN 100として扱う
  • VLANにIPアドレスを振る
    (config)# interface vlan 100
    (config-if)# ip address 192.168.1.1 255.255.255.0
    (config)# ip default-gateway 192.168.1.254
  • 宛先アドレスとの疎通確認
    > ping 192.168.0.1
  • 宛先アドレスまでの経路確認
    > traceroute 192.168.0.1 numeric
    • numericを付けるとDNS逆引きしない
  • IPv4インタフェースの確認
    > show ip interface summary
  • ARP情報の確認
    > show ip arp interface vlan 100

LAG

  • 設定可能数
    • 8p/ch
    • 32ch/台
  • リンクアグリゲーションの接続状態
    > show channel-group 10
    > show channel-group detail
  • リンクアグリゲーションの設定
    # interface range gigabitethernet 0/1-2
    (config-if-range)# channel-group 10 mode active
    • チャネルグループ:1-32
    • モード: on, active, passive
  • LAG振り分け方法の設定
    # port-channel load-balance src-ip
    • 振り分けルール: dst-ip, dst-mac, dst-port, src-dst-ip, src-dst-mac, src-dst-port, src-ip, src-mac, src-port
  • チャネルの削除
    # interface gigabitethernet 0/1-2
    (config-if)# shutdown
    (config-if)# no channel-group
    • または
      # interface gigabitethernet 0/1-2
      (config-if)# shutdown
      (config-if)# exit
      # no interface port-channel 10
    • いずれにしても一旦ポートをshutdownする必要がある。
  • スタンバイリンク機能
    (config)# interface port-channel 10
    (config-if)# channel-group max-active-port 2
    • 最大2ポートしかリンクアップしない
    • channel-group max-active-port 2 no-link-down にすると、全ポートリンクアップするが最大2ポートのみ送信する。
    • lacp port-priority 300のようにpriorityを設定できる。

スパニングツリー

  • STPについてはまだまとめていない。

ポートのリンクアップの速度を上げる

  • ポートのアップリンクに20~50秒程度かかるとき。
    (config)# spanning-tree portfast default
    • STPの機能で、ブロッキング→リスニング→ラーニングを経てフォワーディングするのを待てないせっかちさん向け。
    • portfast機能をデフォルトで設定して、いきなりフォワーディングさせる。
    • STPでループしないこと前提で設定すること。
      • STPを組むときはdefaultをこれで設定し、ポートごとにdisableを設定するらしい。

DHCPサーバ

  • DHCPサーバ
    • L2のくせにL3レベルを喋れる。
    • VLANに対して有効にできる。
    • 特定のMACアドレスに対して固定IPを払い出すこともできる。
  • DHCP有効
    (config)# service dhcp vlan 100
  • DHCP割り当て不可アドレス範囲(複数回指定可能)
    (config)# ip dhcp excluded-address 192.168.1.1 192.168.1.126
    (config)# ip dhcp excluded-address 192.168.1.251 192.168.1.254
  • DHCP割り当てプールの定義
    (config)# ip dhcp pool Group1
  • リースするネットワークの定義
    (dhcp-config)# network 192.168.1.0 255.255.255.0
  • デフォルトリース時間
    (dhcp-config)# lease 1 0 0 0
    • 1日間0時間0分0秒
  • リースするオプション情報
    (dhcp-config)# default-router 192.168.1.254
    (dhcp-config)# dns-server 192.168.1.2
    (dhcp-config)# netbios-name-server 192.168.1.2
  • 設定情報を表示
    > show ip dhcp import
  • 割り当て可能なIPアドレス数の確認
    > show ip dhcp server statistics
  • 配付したIPアドレスの確認
    > show ip dhcp binding
  • 衝突IPアドレス(プールしているのに使用されているアドレス)情報を表示
    > show ip dhcp conflict
  • DHCPサーバを再起動
    # restart dhcp

ストームコントロール

  • 設定
    (config)# interface gigabitethernet 0/10
  • ブロードキャストフレーム
    (config-if)# storm-control broadcast level pps 50
    • 閾値50パケット/秒
  • マルチキャストフレーム閾値
    (config-if)# storm-control multicast level pps 500
    • 500パケット/秒
  • ユニキャストフレーム閾値
    (config-if)# storm-control unicast level pps 1000
    • 1000パケット/秒
  • 検出時の挙動
    (config-if)# storm-control action inactivate
    • 検出したらログを表示しつつinactiv状態にする。自動復帰しないので再開させるにはactivateする必要がある。

L2ループ検知

  • ポートの種別
    • no loop-detection : 検知ポート(デフォルト)
      • L2ループ検知フレームは送信せず、ループ検知時はログ表示のみでactiveのまま
    • send-inact-port : 検知送信閉塞ポート(SI)
      • L2ループ検知フレームを送信、ループ検知時は当該ポートをinactive
    • send-port : 検知送信ポート(S)
      • L2ループ検知フレームを送信、ループ検知時はログ表示のみでactiveのまま
    • exception-port : 検知対象外ポート
      • 何もしない
    • uplink-port : アップリンクポート(U)
      • L2ループ検知フレームを送信せず、ループ検知時は送信元ポートに種別ごとの動作をさせる。
      • 下位に流したフレームが何故か上位(コアネットワーク)に戻ってきたとき、上位を閉塞させず、下位を閉塞させるための仕様。
  • L2ループ検知機能有効
    (config)# loop-detection enable
  • アップリンクポート指定
    (config)# interface range gigabitethernet 0/1-2
    (config-if-range)# loop-detection uplink-port
    (config-if-range)# exit
  • 検知送信閉塞ポートに設定
    (config)# interface range gigabitethernet 0/3-4
    (config-if-range)# loop-detection send-inact-port
    (config-if-range)# exit
  • ループ検知フレームの送信間隔
    (config)# loop-detection interval-time 60
  • ループ検知フレームの検出閾値
    (config)# loop-detection threshold 100
    • フレームをthreshold回受信したら閉塞
  • ループ検知フレームを最後に受信してからの保持秒数
    (config)# loop-detection hold-time 60
    • フレームの検出時間(hold-time回/threshold秒)
  • 自動復旧時間(active状態に戻す)の設定
    (config)# loop-detection auto-restore-time 300
  • ループ検知の情報
    show loop-detection
  • ループ検知の統計
    show loop-detection statistics
  • ループ検知のログ情報
    show loop-detection logging

監視系

SNMP

  • MIB
    • ZabbixはCISCO IOSのテンプレートでポート系は取得できる。
    • ハードウェア系は取得できなかったので、そのうちテンプレ作る。
  • MIBアクセス許可の設定
    (config)# access-list 1 permit 192.168.0.1 0.0.0.0
    • アクセスリスト1の定義 192.168.0.1 (0.0.0.0はmaskではなくwildcard指定)
  • コミュニティの定義
    (config)# snmp-server community "public" ro 1
    • コミュニティ "public", Read Only(ro), アクセスリスト 1
    • アクセスリストは省略でき、省略すると制限なしになる。
  • ホスト情報の定義
    hostname "L2-test"
    snmp-server location "okkun-lab server room rack1 22U"
    snmp-server contact "SUNAGAWA Hiroyuki"
    • hostnameはホスト名やプロンプトにも反映される。
  • SNMPトラップ送信の設定
    (config)# snmp-server host 192.168.0.1 traps "public" version 1 snmp

syslog出力の設定

  • syslogサーバの指定
    (config)# logging host 192.168.0.1

ファームウェアのアップデート

  • 最新ファームウェアはサポートを受けていないともらえない。
  • /usr/var/updateにk.imgを置いて、
    # cd /usr/var/update
    # ppupdate k.img