VMware ESXi 5 サーバを構築

いるもの

  • VMwareサイトからisoダウンロード
    • CD-Rに焼く
  • USBメモリにインストール
    • Transcend T3 2GBを使った
  • サーバ
    • 推奨ハードはいわゆるサーバ機に限られているので、
      今回はお安く Asus P5KPRO + Intel Core2Quad Q9450 + JEDEC PC2-DDR6400 2GB x 4。
      結局メモリが足りないので、PC2-DDR5300 4GB x 4 とかいう無茶苦茶な動かし方をしている。
    • ハードディスクは AHCI を認識しなかったので、未使用。
    • そのほかの構成は Tips/VMware/ESXi/3.5 と同じ

構築

  • USBメモリとCDを入れて起動
    • 指示に従ってインストールするだけ
    • ESX4系からはUSBメモリへのインストールがサポートされた。

トラブルシューティング

スクリーンショットが撮れない

  • ローカルPC上でWinShotを起動
  • タスクトレイ上のアイコンを右クリック→プレビュー表示→コントロール/クライアント
  • マウスカーソルが手になったらコンソール画面上をクリック
  • コンソール画面だけのスクリーンショットが撮れる

SNMP

  • SSH有効化
    • クライアントから 構成 - セキュリティプロファイル - サービス
    • SSHを「ホストに連動して開始および停止」
  • SNMP有効化
    • SSHでESXi 4.1サーバにログイン
    • vi /etc/vmware/snmp.xml
      • <config><snmpSettings><enable>true</enable><communities>public</communities>
    • /sbin/services.sh restart

NFS

  • ゲストOSのイメージやスワップをESXiのディスクに置くと、速度が遅すぎたり、RAID組むために高価なカードを買ったりと、面倒。
    • そこそこパワーのあるNFSサーバを建てて、それをESXiからマウントすればそこそこお安く速度が出る。
    • ESXiは前述のUSBディスクだけ積み、HDDはおろか、光学ドライブすら搭載しないホストのできあがり。

trunkとかチーミングとかPort-channelとか

  • L2スイッチを使って耐障害性と高速化を図ってしまえという作戦。
  • Cisco Catalystと、NIC2枚刺ししたESXiを用意し、2本のLANで結線する(最初は1本だけ結線しておく)
  • スイッチの設定
    port-channel load-balance src-dst-ip
    !
    interface Port-channel 1
     description Po-ESXi
     switchport trunk allowed vlan 2,3
     switchport mode trunk
    !
    interface GigabitEthernet0/4
     description Gi-Po-ESXi-1
     switchport trunk allows vlan 2,3
     switchport mode trunk
     channel-group 1 mode on
    !
    interface GigabitEthernet0/8
     description Gi-Po-ESXi-2
     switchport trunk allows vlan 2,3
     switchport mode trunk
     channel-group 1 mode on
    !
  • ESXiの設定
    • クライアントコンソールのホストの「構成」タブ、ハードウェア「ネットワーク」、標準スイッチ「プロパティ」(右上のプロパティではなく、ネットワーク図の右上)
    • vswitchで「編集」、NICチーミングのロードバランシングを「IPハッシュに基づいたルート」、ネットワークのフェイルオーバー検出を「リンク検出のみ」
  • 参考